Mainstream Technologies

MTI Blog

If you use Firefox…?

If you use Firefox, please check that it is up to date. This is related to a warning that Firefox sent out yesterday about a zero-day exploit being seen in the wild.

We have automated updates setup but they may only run once a week. Just to be sure we are covered from this zero-day exploit please check your version of Firefox is up to date. You should have 72.0.1 or later.

Here’s how to set it manually check for updates

  1. On the menu bar click the triple bar near the upper right corner
  2. Select Help, About Firefox.
  3. A window will open and show you the version and if it is up to date.

Reference:

https://www.mozilla.org/en-US/security/advisories/mfsa2020-03/

Daniel Weatherly
Director of Security Services
Mainstream Technologies Inc.
501-801-6706

Custom Software Icon

Completely Custom
Software Solutions

Custom Software
Managed Services Icon

Peace of Mind,
Proactive IT Services

Managed Services
Hosting Solutions Icon

Compliance Centric
Hosting and Colocation

Hosting Solutions